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1 Introduction

Welcome to the Manzanita Systems MPEG Stream Identifier (MPEGID).  MPEGID is an easy-to-use program
with a full graphical user interface (GUI).  It rapidly identifies and characterizes MPEG and related format media
files that are commonly used in today's digital video and streaming applications.  MPEGID tells you the type of
the file and displays important properties of its content.  Both elementary stream files and multiplexed stream
files can be identified with MPEGID.  If the input file is a multiplexed stream, individual elementary streams
within the multiplex will also be identified and their properties will be displayed.

MPEGID identifies all of the following types of media streams:

· MPEG-1 Video Elementary Streams

· MPEG-2 Video Elementary Streams

· MPEG-4 Part 10 / H.264 / AVC Video Elementary Streams

· MPEG-4 Part 2 Video Elementary Streams

· MPEG Layers I and II Audio Elementary Streams

· MP3 (MPEG Layer III) Audio Elementary Streams

· AC-3 (Dolby Digital) Audio Elementary Streams

· Advanced Audio Coding (AAC) Elementary Streams

· Enhanced AC-3 (E-AC-3, Dolby Digital Plus) Audio Elementary Streams

· MPEG-4 (HE-AAC and HE-AAC version 2) AAC Elementary Streams

· DTS (Digital Theater Systems) Audio Elementary Streams

· SMPTE 302M Audio Elementary Streams

· MPEG-1 System Streams

· MPEG-2 Program Streams

· MPEG-2 Transport Streams

· MPEG-4 (MP4) ISO Base Media Files

· Video Object (VOB) Streams

· DVB Subtitle and ITU-R System B Teletext Streams

· SCTE 35 DPI Cueing Message Streams

MPEGID has an integrated Demultiplexer tool, which allows you to extract and save video and audio elementary
streams from existing system stream, program stream, VOB, transport stream, or MPEG-4 media files.

A command line executable is included with the MPEGID installation.  It enables execution of MPEGID in batch
files or scripts for high-volume applications.

The Demultiplexer tool and command line MPEGID are only available with the full, registered version of
MPEGID, not the demo version.
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1.1 What's New in MPEGID Version 3.0

MPEGID Version 3.0 is a major release that has the following new features: 

· MPEG-4 Part 2 video elementary streams are supported.

· MPEG-4 High Efficiency AAC (HE-AAC) audio elementary streams are supported.

· DVB subtitle streams and SCTE 35 DPI (splicing) messages streams are recognized.

· MPEG-4 ISO base media files are supported.

· Enhanced AC-3 substreams and small block frames are fully supported.

· MPEG Audio Layers 1-3 low sample rates are supported.

· Descriptor data found in transport stream PSI tables is displayed.

· Demultiplexer tool can demultiplex MPEG-4 media files.

· Support for Windows Vista is added.

1.2 Overview

Identifying and characterizing a media file with MPEGID is as easy as dragging and dropping the file from a file
browser/explorer window onto the MPEGID interface.  If the input file is a video or audio elementary stream,
MPEGID will display a list of properties that characterize its content.  If the file is a multiplexed stream, a tree
structure is displayed that illustrates the hierarchy of components in the multiplex.  The properties of an
individual elementary stream in the multiplex are highlighted when the node that represents it in the tree is
selected.

For MPEG-1, MPEG-2, MPEG-4 Part 10 / H.264 / AVC, and MPEG-4 Part 2 video elementary streams,
MPEGID may display the following properties:

· File Size

· Duration

· MPEG Profile

· MPEG Level

· Bit Rate

· Frame Rate

· Resolution

· Aspect Ratio

For MPEG Layers I, II and III (MP-3), AAC, AC-3, Enhanced AC-3, DTS, and HE-AAC audio elementary
streams, MPEGID may display the following properties:

· File Size

· Duration

· Layer (MPEG only)
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· ADIF or ADTS Format (AAC only)

· Bit Rate

· Sample Rate

For SMPTE 302M audio elementary streams, MPEGID displays the following properties:

· Number of Channels

· Channel ID

· Sample Size

For MPEG-1 System, MPEG-2 Program, and VOB streams, MPEGID displays the following properties:

· File Size

· Duration

· Multiplex Bit Rate

· stream_id of each elementary stream

· VOB subtype of each Dolby AC-3 elementary stream (VOB streams only)

· Properties of each elementary stream

For MPEG-4 media files, MPEGID displays the following properties:

· File Size

· Duration

· track_ID of each elementary stream

· Properties of each elementary stream

For MPEG-2 transport streams, MPEGID displays the following properties:

· File Size

· Duration

· Multiplex Bit Rate

· program_number associated with each program

· PCR PID and PMT PID for each program

· stream_id and stream_type of each elementary stream

· PID of each elementary stream

· Properties of each elementary stream

To give you the fastest results, MPEGID only inspects the beginning of the input file to determine its contents. 
Therefore, the characteristics that are displayed are those that are present initially in the stream.  Any changes,
for example, in the bit rate, that occur later in the stream will not be noted.  
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1.3 About this Manual

This online manual completely documents the use of MPEGID.  The following chapters are presented:

· Getting Started  covers installation of MPEGID.

· The MPEGID User Interface  describes all menus, controls, and displays available in the MPEGID
program.

· Using MPEGID  details how to identify media files with MPEGID.  It describes the results that are
displayed by MPEGID for each type of file.

· Additional Support  presents Frequently Asked Questions (FAQ) about MPEGID, a list of pertinent
references, and tips for getting additional help and support.

· Purchasing and License Agreement  gives information for purchasing the full version of MPEGID and
outlines the terms of the license agreement that covers the MPEGID software and associated
documentation.

This manual assumes that you have familiarity with the basic MPEG syntax and semantics.
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2 Getting Started

This chapter helps you install and start MPEGID.  It contains the following sections: 

· Installing MPEGID  describes installation of the MPEGID program to your hard drive.

· Starting MPEGID  explains how to start the MPEGID program on your computer.

· Installing Your License Key  describes how to install the key that allows you to run the full version of
MPEGID.

2.1 Installing MPEGID

The latest version of MPEGID is always available for download from the Manzanita Systems website at:

http://www.manzanitasystems.com/mpegid.html   

MPEGID is available for the following platforms:

· Windows 2000, Server 2003, XP, or Vista

· Linux

· Mac OS X  

2.1.1 Windows 2000, Server 2003, XP, or Vista

MPEGID is provided in a single self-extracting executable for installation on Windows 2000, Server 2003, XP,
and Vista systems.  Typically, the file name includes the version number, e.g.,  mpegid-3.0.exe.

 Windows 2000, Server 2003, XP, or Vista is recommended for MPEGID V3.0.  MPEGID may work on
Windows 98, Windows Me, and Windows NT, but it is not officially supported on these platforms.

To install MPEGID from the self-extracting installation file on Windows 2000 / Server 2003 / XP / Vista:

 1. Open the folder in which you downloaded the MPEGID installation file using My Computer or the Windows
Explorer and double-click on it.   

2. Follow the on-screen instructions to install MPEGID on your computer.   

2.1.2 Linux

The minimum system requirement for installing MPEGID on a Linux system is:

· i386+ compatible processor

Both RPM and tar distributions are available for installation of MPEGID on Linux.  The files will be named, for
example, mpegid-3.0-1.i386.rpm and mpegid-3.0.tgz. 
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To install MPEGID from the RPM package:

 1. Use rpm per your normal procedure to install the MPEGID package. 

 For example:
su
rpm -i mpegid-3.0-1.i386.rpm

To install MPEGID from the tar file: 

1. Log in as root user and unpack the archive into /opt.  

 For example:
su
cd /opt
tar xzf /path/to/archive/mpegid-3.0.tgz

2. Create symbolic links from the MPEGID executables to a directory which is in your PATH variable, or
include the location of the MPEGID executables in the PATH variable.  The MPEGID GUI program is
called gmpegid.  The command line version of MPEGID is called mpegid.

 For example:
ln -s /opt/manzanita/mpegid/bin/gmpegid /usr/bin/gmpegid
ln -s /opt/manzanita/mpegid/bin/mpegid /usr/bin/mpegid

or
export PATH=$PATH:/opt/manzanita/mpegid/bin

3. If the system is running GNOME or KDE, a desktop entry can be created by making links to files in the
/desktop directory.

 For example:
ln -s /opt/manzanita/mpegid/desktop/mpegid.desktop
/usr/share/applications/mpegid.desktop
ln -s /opt/manzanita/mpegid/desktop/mpegid.png
/usr/share/icons/hicolor/32x32/apps/mpegid.png

 

2.1.3 Mac OS X

The minimum system requirements for installing MPEGID on Mac OS X are:

· Mac OS X v10.3.9 (Panther) or newer

MPEGID is provided as a disk image, e.g., mpegid-3.0.dmg, for installation on Mac OS X systems.  

To install MPEGID from the disk image:

1. Double-click on the mpegid-3.0.dmg file icon to mount it as a disk image volume.  

2. Open the MPEGID volume and drag the MPEGID application to your Applications folder.

 In order to run the command line version of MPEGID (enabled only with the full, registered version), create a
symbolic link from the MPEGID executable to a directory which is in your PATH variable, or include the location
of the MPEGID executables in the PATH variable. 

 For example:
ln -s /Applications/mpegid.app/Contents/MacOS/mpegid /usr/bin/mpegid
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2.2 Starting MPEGID

After MPEGID is installed, it will run as a demo version until you unlock the full version with a license key.  

The procedure for starting the GUI version of the MPEGID program is the same whether you are running the
demo version or the full version.  For a description of the command line version of MPEGID, see the section 
Identifying from the Command Line .

To start MPEGID on Windows 2000 / Server 2003 / XP / Vista:

1. Choose Start > Programs > Manzanita Systems > MPEGID 3 from the Windows Start menu, or
double-click the  MPEGID icon on the Desktop.

To start MPEGID on Linux or Solaris:

1. If you have created a desktop entry for MPEGID, choose the MPEGID item from the Sound & Video
(Multimedia) submenu of your Start (Launch) menu.

or

1. At a shell prompt, enter the line:

gmpegid

 If you get a message that the name that you entered is not recognized as a command, then the
MPEGID executable is not in a location that is recognized by the PATH environment variable.  You should
either create a symbolic link from the MPEGID program to a directory which is in your PATH variable or
include the location of the MPEGID program in the PATH variable.  

To start MPEGID on Mac OS X:

1. Double click on the MPEGID application in your Applications folder.

On all platforms, if you have not yet installed a valid license key, a dialog box will be displayed that gives you
information about the demo version.  After a few seconds, the Use Demo button will be active.  The Enter
License Key button allows you to install a new license key .  Click Use Demo to open the MPEGID program
in demo mode.  You may now begin identifying your media files.

If the license key for the full version has been installed, or if you have a hardware dongle for any Manzanita
product connected to your computer, then the full version of the MPEGID program will open.  You may now
begin identifying your media files.

2.3 Installing Your License Key

MPEGID is initially installed as a demo version.  You will need a valid MPEGID license key or have a hardware
dongle for any licensed Manzanita product on your system to unlock the full version.  With the full version, you
will have access to the Demultiplexer and command line execution.

You will receive a license key when you register your copy of MPEGID with Manzanita Systems and pay a
registration fee.  The section, Purchasing a Registered Copy , in this manual gives instructions on how to
order your registered copy.

 It is recommended that you record and save your license key.  You will need it if you ever re-install
MPEGID.

39
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To install the MPEGID license key:

1. Start the MPEGID GUI program. 

 A dialog box will be displayed that gives you information about the demo version.  

2. Click the Enter License Key button.

3. Enter your license key in the labeled textbox.  The license key is 16 characters long, separated into four
groups of four characters each with a dash (-).  It should entered in the format
NNNN-NNNN-NNNN-NNNN.

For example:

1234-5678-90AB-CDEF

4. Enter your company name or organization in the textbox labeled Company Name.

5. Click the Continue button. 

If the license key was successfully installed, a dialog box will appear informing you that the MPEGID
program will quit.

6. Start the MPEGID GUI program again. 

The MPEGID user interface will open.  You may now begin identifying your media files.
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3 The MPEGID User Interface

The MPEGID user interface consists of a single, simple window. It has the following components:

 

 

Menu Bar
The Menu Bar provides menus to open an input media file, save a report file, run the Demultiplexer, and set
display preferences.  It also provides access to the online help system.

Stream Title Bar
The Stream Title Bar tells you the type of the input media file.

Multiplex Pane
The Multiplex Pane shows a graphical representation of the contents of the input media file.  It is only displayed
if the input file is a multiplexed stream.

Property Pane
The Property Pane displays a list of all stream properties and their values.  If the input file is a multiplexed
stream, the properties for the component that is currently selected in the Multiplex Pane are highlighted.

15
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3.1 Menu Bar

The Menu Bar at the top of the interface gives you access to MPEGID's main functions.  The tables below
summarize the commands on the Menu Bar.

File >

Identify... Opens the Open Input File dialog box that allows
you to specify a media file for identification and
characterization.

Ctrl+O

Save Report As... Saves the properties of the current input file in a
text file.

Ctrl+S

Quit Closes the MPEGID program. Ctrl+Q

Edit >

Demux... Extracts a single, selected elementary stream from
a multiplexed stream and saves it as a binary file. 
The input file must be an MPEG-1 system stream,
MPEG-2 program stream, VOB, MPEG-2 transport
stream, or MPEG-4 media file.

Ctrl+D

Preferences... Sets the format (decimal or hexadecimal) in which
stream_id, PID, and stream_type values are
displayed.

Help >

Manual Opens the online User's Manual.

About Displays information about your copy of the
MPEGID program.
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3.2 Stream Title Bar

The Stream Title Bar spans the MPEGID interface just below the Menu Bar.  When the MPEGID program
initially starts, the Stream Title Bar will be a blank space.  After you open an input file, its type will be displayed
in the Stream Title Bar as both a description and an icon.

The following types may be displayed in the Stream Title Bar:

Icon Description

MPEG-1 Video Elementary Stream

MPEG-2 Video Elementary Stream

MPEG-4 AVC/H.264 Video Elementary Stream

MPEG-4 Part 2 Video Elementary Stream

MPEG Layer I Audio Elementary Stream

MPEG Layer II Audio Elementary Stream

MPEG Layer III Audio Elementary Stream*

Dolby AC-3 Audio Elementary Stream

Dolby Enhanced AC-3 Audio Elementary Stream

DTS Audio Elementary Stream

Advanced Audio Coding (AAC) Elementary Stream

MPEG-4 AAC Elementary Stream

SMPTE 302M Audio Elementary Stream

MPEG-1 System Stream

MPEG-2 Program Stream**

MPEG-2 Transport Stream

MPEG-4 ISO Base Media File

Unknown***

* MP-3 Audio Streams are identified as MPEG Layer III Audio Elementary Streams.

** Video Object (VOB) files are identified as MPEG-2 Program Streams.

*** The input file was not recognized by MPEGID.
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3.3 Multiplex Pane

The Multiplex Pane occupies the panel on the left side of the MPEGID window below the Stream Title Bar when
the input file is a multiplexed stream (MPEG-1 System Stream, MPEG-2 Program Stream, VOB, MPEG-2
Transport Stream, or MPEG-4 Media File).   It is not present when the input file is an elementary stream.

The Multiplex Pane displays a tree structure that symbolizes the multiplexed stream.  The root node of the tree
represents the multiplexed stream itself.  Each node that branches from the root node represents a component
of the multiplex.  For example, the Multiplex Pane for an MPEG-2 Program Stream that contains one video
elementary stream and two audio elementary streams will display a Program Stream root node with one video
branch node and two audio branch nodes.  When you click on a node in the Multiplex Pane, the properties of
the corresponding component are highlighted in the Property Pane.  

The following types of nodes may appear in the Multiplex Pane:

Icon Description

MPEG-1 Video Elementary Stream

MPEG-2 Video Elementary Stream

MPEG-4 AVC/H.264 Video Elementary Stream

MPEG-4 part 2 Video Elementary Stream

MPEG Layer I Audio Elementary Stream

MPEG Layer II Audio Elementary Stream

MPEG Layer III Audio Elementary Stream*

 Dolby AC-3 Audio Elementary Stream

Dolby Enhanced AC-3 Audio Elementary Stream

DTS Audio Elementary Stream

Advanced Audio Coding (AAC) Elementary Stream

MPEG-4 AAC Elementary Stream

SMPTE 302M Audio Elementary Stream

Private Stream, User Private Stream

DVB Subtitle Stream

MPEG-1 System Stream

MPEG-2 Program Stream**

 MPEG-2 Transport Stream

MPEG-4 ISO Base Media File

MPEG-2 Program

* MP-3 Audio Streams are identified as MPEG Layer III Audio Elementary Streams.

** Video Object (VOB) files are identified as MPEG-2 Program Streams.
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3.4 Property Pane

If the input media file is a video or audio elementary stream, then the Property Pane will display a list of
properties that characterize the stream.  If the input file is a multiplexed stream (MPEG-1 System Stream,
MPEG-2 Program Stream, VOB, MPEG-2 Transport Stream, or MPEG-4 Media File), then the Property Pane
will occupy the panel to the right of the Multiplex Pane.  In this case, the Property Pane displays all properties of
the multiplex with indenting to distinguish individual components and to indicate hierarchy.  When you click on a
node in the Multiplex Pane, the properties of the corresponding component are highlighted in the Property
Pane. 

The chapter, Using MPEGID , in this manual describes the properties for each stream and multiplex
component that are displayed in the Property Pane.

20
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4 Using MPEGID

Identifying and characterizing a media file is as simple as opening up the file in MPEGID.  MPEGID will display
important properties of the stream that the file contains.  If the input file contains a multiplexed stream (MPEG-1
System Stream, MPEG-2 Program Stream, VOB, MPEG-2 Transport Stream, or MPEG-4 Media File), MPEGID
will also display a graphical representation of the multiplex. 

This chapter contains the following sections:

· Identifying Your Media File  explains how to open an input media file for identification and
characterization.

· Viewing the Multiplex Structure  describes use of the graphical representation that is displayed for
multiplexed streams.

· Interpreting Stream Properties  gives a detailed description of the properties that are displayed for
each type of stream and multiplex component.

· Saving a Report File  tells how to save the stream properties in a text file.

· Demultiplexing an Elementary Stream  documents use of the demultiplexer utility.

· Identifying from the Command Line  describes the command line version of MPEGID.

4.1 Identifying a Media File

You can open a media file in MPEGID by dragging and dropping the file from a file browser/explorer window
onto the MPEGID interface, or by using the Identify function on the File Menu.  MPEGID will automatically
identify the input file once it has been opened.  

To open and identify an input media file using drag-and-drop:

1. Select the input file in a graphical file system browser/explorer.  Drag and drop the file onto the Stream
Title Bar, Multiplex Pane or Property Pane of the MPEGID interface.

MPEGID will open the input file and identify it.  The Stream Title Bar will display the identity of the file.  If
the input file is an elementary stream, a list of properties will be displayed in the Property Pane below the
Stream Title Bar.  If the input file is a multiplexed stream, then both the Multiplex Pane and Property
Pane will display the results of the identification.

If MPEGID does not recognize the format of the input file, it will display an error message.

To open and identify an input media file using the File Menu Identify function:

1. Choose File > Identify... from the Menu Bar.  The Open File dialog box will appear.

2. Browse your system to select the input file, then click Open.

The Open File dialog box will close, and MPEGID will open the input file and identify it.  The Stream Title
Bar will display the identity of the file.  If the input file is an elementary stream, a list of properties will be
displayed in the Property Pane below the Stream Title Bar.  If the input file is a multiplexed stream, then
both the Multiplex Pane and Property Pane will display the results of the identification.

If MPEGID does not recognize the format of the input file, it will display an error message.
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4.2 Viewing the Multiplex Structure

If your input media file is an MPEG-1 System Stream, MPEG-2 Program Stream, VOB*, MPEG-2 Transport
Stream, or MPEG-4 ISO Base Media File, MPEGID will display a tree diagram in the Multiplex Pane that
represents the contents of the multiplexed stream.  This tree illustrates the hierarchical structure of the
multiplex, showing the individual elementary streams that are contained in it.  If the input stream is an MPEG-2
Transport Stream, the tree will show all programs that are defined in the multiplex, and all elementary streams
that are mapped to each program.

The root node of the tree represents the multiplexed stream itself.  Each node that branches from the root node
represents a component of the multiplex.  For MPEG-1 System Streams, MPEG-2 Program Streams, MPEG-4
ISO Base Media Files, and VOBs, only elementary stream nodes may branch from the root node.  For MPEG-2
Transport Streams, one or more MPEG-2 Program nodes branch from the root node.  Each MPEG-2 Program
node may have one or more elementary stream nodes branching from it.  See the section, Multiplex Pane ,
for a description of the types of nodes that may be depicted in the Multiplex Pane.

When you click on a node in the Multiplex Pane, the properties of the corresponding component are highlighted
in the Property Pane. 

* VOB files are identified by MPEGID as MPEG-2 Program Streams.

4.3 Interpreting Stream Properties

The Property Pane displays important properties of the input stream.  If the input file is a multiplexed stream,
then the Property Pane presents the properties hierarchically to mirror the graphical representation in the
Multiplex Pane.  When an individual node in the Multiplex Pane is selected, the properties of the corresponding
component will be highlighted in the Property Pane.

Any portion of the results that are displayed in the Property Pane can be selected, copied to the clipboard, and
pasted in a document.  You can also save the entire contents of the Property Pane in a report file  for later
reference.

This section gives detailed descriptions of the properties that are displayed for each type of stream and
multiplex component.

 It is important to remember that MPEGID only looks at the beginning of the input file to determine its identity
and stream properties.  Therefore, any changes that occur later in the file will not be reflected in the displayed
properties.

The Property Pane displays the following types of properties:

· General Stream Properties

· MPEG-1 Video Elementary Stream Properties

· MPEG-2 Video Elementary Stream Properties

· MPEG-4 AVC/H.264 Video Elementary Stream Properties

· MPEG-4 Part 2 Video Elementary Stream Properties

· MPEG Audio Elementary Stream Properties

· AC-3 / Enhanced AC-3 Audio Elementary Stream Properties
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· DTS Audio Elementary Stream Properties

· AAC Elementary Stream Properties

· MPEG-4 AAC Elementary Stream Properties

· SMPTE 302M Audio Elementary Stream Properties

· Private Stream Properties

· User Private Stream Properties

· DVB Subtitle Stream Properties

· MPEG-2 Program Properties

· MPEG-1 System Stream Properties

· MPEG-2 Program Stream Properties

· MPEG-4 ISO Base Media File Properties

· MPEG-2 Transport Stream Properties

30

31

32

33

34

34

35

36

37

37

37

37



Using MPEGID 23

Copyright ©  2006 - 2008 Manzanita Systems, Inc.

4.3.1 General Stream Properties

For all supported types of media files, the Property Pane will display the following properties:

File Size

The File Size property gives the size of the input file in bytes. 

Duration

The Duration property gives an estimate of the length of the stream in hours, minutes, and seconds. 
MPEGID bases this estimate on the File Size of the input file and the bit rate that is determined from the
stream.  For video and audio elementary streams, the bit rate is explicitly specified in the stream syntax. 
For MPEG-1 System Streams and MPEG-2 Program Streams, the bit rate is the initial mux_rate value
specified in the stream.  For MPEG-2 Transport Streams, MPEGID estimates the bit rate from the PCR
(Program Clock Reference) values in the beginning of the stream.  Note that this property is only an
estimate.  The actual duration will be different if a bit rate change occurs in the stream, or if the actual rate
varies from that specified in the stream syntax.
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4.3.2 MPEG-1 Video Elementary Stream Properties

The following properties are displayed in the Property Pane for an MPEG-1 Video Elementary Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the video elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be displayed in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the MPEG-1 Video
Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the video elementary stream in
the Program Map Table.  Generally, MPEG-1 video elementary streams are assigned a stream_type value
of 1.  The value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which
the stream_type property is displayed is set by the Edit > Preferences menu function.  The stream_type
property is only displayed if the MPEG-1 Video Elementary Stream is a component of an MPEG-2
Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors in the PMT that are associated with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present are displayed on a separate line.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the video elementary
stream.   Generally, MPEG-1 video elementary streams are assigned a stream_id value from 224 to 239
(0xE0 to 0xEF).   The value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The
base in which the stream_id property is displayed is set by the Edit > Preferences menu function.  The
stream_id property is only displayed if the MPEG-1 Video Elementary Stream is a component of an
MPEG-1 System Stream, MPEG-2 Program Stream, or MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the elementary stream in the MPEG-4 media file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the video elementary stream
syntax.  The Bit Rate property will be set to "VBR" if the video stream is variable bit rate.

Frame Rate

The Frame Rate property is the frame rate in frames per second (fps) that is specified in the video
elementary stream syntax.

Resolution

The Resolution property is given as width x height, where width is the width in samples and height is the
height in lines of the displayable part of a picture as specified by the horizontal_size and vertical_size fields
in the video sequence header.

Aspect Ratio

The Aspect Ratio property is the value specified in the aspect_ratio_information field in the video sequence
header.
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4.3.3 MPEG-2 Video Elementary Stream Properties

The following properties are displayed for an MPEG-2 Video Elementary Stream:

PID (MPEG-2 Transport Stream only)

This property is the value of the PID that is associated with the video elementary stream.   The value may
be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be displayed in decimal, or if
prefaced with a "0x", in hexadecimal as set by the Edit > Preferences menu function.  The PID property is
only displayed if the MPEG-2 Video Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the video elementary stream in
the Program Map Table.   Generally, MPEG-2 video streams are assigned a stream_type value of 2.  The
value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the
stream_type property is displayed is set by the Edit > Preferences menu function.  The stream_type
property is only displayed if the MPEG-2 Video Elementary Stream is a component of an MPEG-2
Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors in the PMT that are associated with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present are displayed on a separate line.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

This property is the stream_id value that appears in PES headers for the video stream.   Generally,
MPEG-2 video streams are assigned a stream_id value from 224 to 239 (0xE0 to 0xEF).   The value may
be displayed in decimal, or if prefaced with a "0x", in hexadecimal as set by the Edit > Preferences menu
function.  The stream_id property is only displayed if the MPEG-2 Video Elementary Stream is a
component of an MPEG-1 System Stream, MPEG-2 Program Stream, or MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the video elementary stream in the MPEG-4 media file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the video elementary stream
syntax.  If the video stream is variable bit rate, the Bit Rate property will be set to the maximum bit rate at
which the stream is encoded.

Profile

The Profile property is determined from the profile_and_level_indication in the video elementary stream
syntax.  

Level

The Level property is determined from the profile_and_level_indication in the video syntax.  

Frame Rate

The Frame Rate property is the frame rate in frames per second (fps) that is specified in the video
elementary stream syntax.

Resolution

The Resolution property is given as width x height, where width is the width in samples and height is the
height in lines of the displayable part of a picture as specified by the horizontal_size and vertical_size fields
in the video sequence header.

Aspect Ratio

The Aspect Ratio property is the value specified in the aspect_ratio_information field in the video sequence
header.
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4.3.4 MPEG-4 AVC/H.264 Video Elementary Stream Properties

The following properties are displayed in the Property Pane for an H.264 / AVC / MPEG-4 Part 10 Video
Elementary Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the video elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be displayed in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the video stream is a
component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the video elementary stream in
the Program Map Table.   Generally, H.264 / AVC / MPEG-4 Part 10 video streams are assigned a
stream_type value of 27 (0x1B).  The value may be displayed in decimal, or if prefaced with a "0x", in
hexadecimal.  The base in which the stream_type property is displayed is set by the Edit > Preferences
menu function.  The stream_type property is only displayed if the video stream is a component of an
MPEG-2 Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors in the PMT that are associated with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present are displayed on a separate line.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the video elementary
stream.   Generally, video elementary streams are assigned a stream_id value from 224 to 239 (0xE0 to
0xEF).   The value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The base in
which the stream_id property is displayed is set by the Edit > Preferences menu function.  The stream_id
property is only displayed if the video stream is a component of an MPEG-1 System Stream, MPEG-2
Program Stream, or MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the video elementary stream in the MPEG-4 media file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the video elementary stream
syntax.  If the video stream is variable bit rate, the Bit Rate property will be set to the maximum bit rate at
which the stream is encoded.

Profile

The Profile property is determined from the profile_idc in the video elementary stream syntax.  

Level

The Level property is determined from the level_idc in the video elementary stream syntax.  

Frame Rate

The Frame Rate property is the frame rate in frames per second (fps).  It is calculated from the time_scale
and num_units_in_tick fields when they are present in the video stream.

Resolution

The Resolution property is given as width x height, where width is the width in samples and height is the
height in lines of the displayable part of a picture as specified by the horizontal_size and vertical_size fields
in the video sequence header.
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4.3.5 MPEG-4 Part 2 Video Elementary Stream Properties

The following properties are displayed for an MPEG-4 Part 2 Video Elementary Stream:

PID (MPEG-2 Transport Stream only)

This property is the value of the PID that is associated with the video elementary stream.   The value may
be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be displayed in decimal, or if
prefaced with a "0x", in hexadecimal as set by the Edit > Preferences menu function.  The PID property is
only displayed if the video elementary stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the video elementary stream in
the Program Map Table.   The value may be displayed in decimal, or if prefaced with a "0x", in
hexadecimal.  The base in which the stream_type property is displayed is set by the Edit > Preferences
menu function.  The stream_type property is only displayed if the video elementary stream is a component
of an MPEG-2 Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors in the PMT that are associated with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present are displayed on a separate line.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

This property is the stream_id value that appears in PES headers for the video stream.   Generally, video
elementary streams are assigned a stream_id value from 224 to 239 (0xE0 to 0xEF).   The value may be
displayed in decimal, or if prefaced with a "0x", in hexadecimal as set by the Edit > Preferences menu
function.  The stream_id property is only displayed if the video elementary stream is a component of an
MPEG-1 System Stream, MPEG-2 Program Stream, or MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the video elementary stream in the MPEG-4 media file.

Profile & Level

The Profile & Level property is determined from the video elementary stream syntax.

Frame Rate

The Frame Rate property is the frame rate in frames per second (fps) if it is specified in the video
elementary stream syntax.

Resolution

The Resolution property is given as width x height, where width is the width in samples and height is the
height in lines of the displayable part of a picture as specified in the video stream syntax.
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4.3.6 MPEG Audio Elementary Stream Properties

Elementary streams that are encoded as Layer I, II, or III audio are identified as MPEG Audio Elementary
Streams.  Note that MPEG Layer III Audio Elementary Streams are also known as MP-3 Audio Streams.

The following properties are displayed in the Property Pane for an MPEG Audio Elementary Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be displayed in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the MPEG Audio
Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the audio elementary stream in
the Program Map Table.   Generally, MPEG audio Layer I and II elementary streams are assigned a
stream_type value of 3, and Layer III streams have a stream_type value of 4.  The value may be displayed
in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the stream_type property is
displayed is set by the Edit > Preferences menu function.  The stream_type property is only displayed if
the MPEG Audio Elementary Stream is a component of an MPEG-2 Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors in the PMT that are associated with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present are displayed on a separate line.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the audio elementary
stream.   Generally, MPEG audio (all Layers) streams are assigned a stream_id value from 192 to 223
(0xC0 to 0xDF).   The value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The
base in which the stream_id property is displayed is set by the Edit > Preferences menu function.  The
stream_id property is only displayed if the MPEG Audio Elementary Stream is a component of an MPEG-1
System Stream, MPEG-2 Program Stream, or MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the elementary stream in the MPEG-4 media file.

Layer

The Layer property is the value specified by the Layer field in the audio elementary stream syntax.  The
possible values are "1", "2", and "3".  Note that Layer III (3) audio streams are also known as MP-3 audio
streams.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the audio elementary stream
syntax.  

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the audio
elementary stream syntax.
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4.3.7 AC-3 / Enhanced AC-3 Audio Elementary Stream Properties

The following properties are displayed in the Property Pane for a AC-3 (Dolby Digital) and Enhanced AC-3
(Dolby Digital Plus) Audio Elementary Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be displayed in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the audio stream is a
component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the audio elementary stream in
the Program Map Table.   The value may be displayed in decimal, or if prefaced with a "0x", in
hexadecimal.  Generally, AC-3 audio streams are assigned a stream_type value of 129 (0x81), and
Enhanced AC-3 are given a value of 135 (0x87).   The base in which the stream_type property is displayed
is set by the Edit > Preferences menu function.  The stream_type property is only displayed if the audio
stream is a component of an MPEG-2 Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors in the PMT that are associated with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present are displayed on a separate line.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the AC-3 audio elementary
stream.   Generally, AC-3 and Enhanced AC-3 audio streams are assigned a stream_id value of 189
(0xBD).   The value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The base in
which the stream_id property is displayed is set by the Edit > Preferences menu function.  The stream_id
property is only displayed if the audio stream is a component of an MPEG-1 System Stream, MPEG-2
Program Stream, or MPEG-2 Transport Stream.

VOB sub-type (VOBs only)

The VOB sub-type is an identifier that is unique for each Dolby AC-3 stream in the VOB.  The VOB
sub-type property is only displayed if the Dolby AC-3 Audio Elementary Stream is a component of a
VOB-type MPEG-2 Program Stream.  

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the elementary stream in the MPEG-4 media file.

Number of substreams

Indicates the total number of substreams embedded in the E-AC3 stream.  This property is only displayed
if substreams are present. Note the Bit Rate property is the total bit rate of all substreams.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the audio elementary stream
syntax. 

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the audio
elementary stream syntax.
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4.3.8 DTS Audio Elementary Stream Properties

The following properties are displayed in the Property Pane for a DTS Audio Elementary Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be displayed in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the audio stream is a
component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the audio elementary stream in
the Program Map Table.   The value may be displayed in decimal, or if prefaced with a "0x", in
hexadecimal.  Generally, DTS audio streams are assigned a stream_type value of 6.   The base in which
the stream_type property is displayed is set by the Edit > Preferences menu function.  The stream_type
property is only displayed if the audio stream is a component of an MPEG-2 Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors in the PMT that are associated with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present are displayed on a separate line.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the audio elementary
stream.   Generally, DTS audio streams are assigned a stream_id value of 189 (0xBD).   The value may be
displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the stream_id property
is displayed is set by the Edit > Preferences menu function.  The stream_id property is only displayed if
the audio stream is a component of an MPEG-1 System Stream, MPEG-2 Program Stream, or MPEG-2
Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the elementary stream in the MPEG-4 media file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is specified in the audio elementary stream
syntax. 

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the audio
elementary stream syntax.
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4.3.9 AAC Elementary Stream Properties

The following properties are displayed in the Property Pane for an Advanced Audio Coding Elementary Stream,
also referred to as Layer IV or audio with ADTS transport syntax:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be displayed in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the AAC Elementary
Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the AAC elementary stream in
the Program Map Table.   The value may be displayed in decimal, or if prefaced with a "0x", in
hexadecimal.  Generally, AAC streams are assigned a stream_type value of 15 (0x0F).   The base in which
the stream_type property is displayed is set by the Edit > Preferences menu function.  The stream_type
property is only displayed if the AAC Elementary Stream is a component of an MPEG-2 Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors in the PMT that are associated with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present are displayed on a separate line.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the AAC elementary
stream.   Generally, AAC streams are assigned a stream_id value from 192 to 223 (0xC0 to 0xDF).   The
value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the
stream_id property is displayed is set by the Edit > Preferences menu function.  The stream_id property
is only displayed if the AAC Elementary Stream is a component of an MPEG-1 System Stream, MPEG-2
Program Stream, or MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the elementary stream in the MPEG-4 media file.

Layer

The Layer property is the value specified by the Layer field in the audio elementary stream syntax.  AAC is
encoded as Layer 4.

Format

The Format property indicates if the AAC elementary stream is ADIF (Audio Data Interchange Format) or
ADTS (Audio Data Transport Stream). 

Bit Rate

If the Format is ADTS, the stream is always encoded at a variable bit rate.  In this case, the Bit Rate
property is set to "VBR".  If the Format is ADIF, the stream can be either variable or constant bit rate.  If it
is variable bit rate, the Bit Rate property is set to "VBR".  If the stream is constant bit rate, the Bit Rate
property will be set to the rate in bits per second (bps) that is specified in the audio elementary stream
syntax followed by "CBR".

Sample Rate (ADTS only)

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the audio
elementary stream syntax.   The Sample Rate is only displayed if the AAC stream is ADTS.
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4.3.10 MPEG-4 AAC Elementary Stream Properties

The following properties are displayed in the Property Pane for an MPEG-4 AAC Elementary Stream, also
referred to as High Efficiency AAC (HE-AAC) :

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be displayed in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the MPEG-4 AAC
Elementary Stream is a component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the elementary stream in the
Program Map Table.   The value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.
The base in which the stream_type property is displayed is set by the Edit > Preferences menu function.
The stream_type property is only displayed if the elementary stream is a component of an MPEG-2
Transport Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors in the PMT that are associated with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present are displayed on a separate line.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the elementary stream.  
Generally, audio streams are assigned a stream_id value from 192 to 223 (0xC0 to 0xDF).   The value
may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the stream_id
property is displayed is set by the Edit > Preferences menu function.  The stream_id property is only
displayed if the elementary stream is a component of an MPEG-1 System Stream, MPEG-2 Program
Stream, or MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the elementary stream in the MPEG-4 media file.

Audio Object Type

MPEG-4 audio supports many different audio codecs.  The Audio Object Type describes the codec used to
create this MPEG-4 audio stream.

Number of sub-frames

This property gives the number of sub-frames contained in each AAC audio frame.  Sub-frames are used
to expand the number of channels supported by the audio stream.

Bit Rate

HE-AAC is inherently a VBR audio format, but an encoder can adjust the audio quality to create a CBR
stream.  MPEGID will attempt to determine if the rate is CBR, and if so, the calculated rate will be
reported.  If the rate appears to vary, then it will be reported as VBR.

Sample Rate

The Sample Rate is the sampling frequency in samples per second (sps) that is specified in the audio
elementary stream syntax.   
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4.3.11 SMPTE 302M Audio Elementary Stream Properties

The following properties are displayed in the Property Pane for a SMPTE 302M Audio Elementary Stream:

PID (MPEG-2 Transport Stream only)

The PID property is the value of the PID that is associated with the audio elementary stream.   The PID
value may be an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be displayed in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set
by the Edit > Preferences menu function.  The PID property is only displayed if the audio stream is a
component of an MPEG-2 Transport Stream.

stream_type (MPEG-2 Transport Stream only)

The stream_type property is the stream_type value that is associated with the audio elementary stream in
the Program Map Table.   The value may be displayed in decimal, or if prefaced with a "0x", in
hexadecimal.  Generally, SMPTE 302M audio streams are assigned a stream_type value of 6.   The base
in which the stream_type property is displayed is set by the Edit > Preferences menu function.  The
stream_type property is only displayed if the audio stream is a component of an MPEG-2 Transport
Stream.

Descriptors (MPEG-2 Transport Stream only)

Any descriptors in the PMT that are associated with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.

stream_id (MPEG-1 System, MPEG-2 Program, and MPEG-2 Transport Streams only)

The stream_id property is the stream_id value that appears in PES headers for the audio elementary
stream.   Generally, SMPTE 302M audio streams are assigned a stream_id value of 189 (0xBD).   The
value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the
stream_id property is displayed is set by the Edit > Preferences menu function.  The stream_id property
is only displayed if the audio stream is a component of an MPEG-1 System Stream, MPEG-2 Program
Stream, or MPEG-2 Transport Stream.

track_ID (MPEG-4 ISO Base Media Files only)

The track_ID property is the value that identifies the elementary stream in the MPEG-4 media file.

Bit Rate

The Bit Rate property is the rate in bits per second (bps) that is computed from the sample rate, sample
size, and number of channels. 

Number of Channels

This property is the number of channels that are present in the stream as encoded in the audio syntax. 

channel_id

SMPTE 302M supports up to eight channels in one elementary stream.  The Channel ID is the channel
number of the first data channel in this stream.  This feature allows more than eight channels to be carried
using multiple elementary streams.

Sample Size

SMPTE 302M supports 16, 20 and 24 bit word size.  This parameter gives the size of the samples in this
stream.
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4.3.12 Private Stream Properties

MPEG-1 system streams and MPEG-2 program streams can contain privately defined data streams in addition
to audio and video elementary streams.  Like audio and video, these streams are segmented in PES packets,
however, their stream_id identifies them as Private Streams.   MPEGID reports the presence of Private
Streams, however, it does not inspect the content.

The following property is displayed in the Property Pane for a Private Stream:

stream_id 

The stream_id property is the stream_id value that appears in PES headers for the Private Stream.  
Private Streams are identified by the stream_id values of 0xBD (private_stream_1) and 0xBF
(private_stream_2).   The value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal. 
The base in which the stream_id property is displayed is set by the Edit > Preferences menu function.  

4.3.13 User Private Stream Properties

MPEG-2 transport streams can contain privately defined data streams in addition to audio and video elementary
streams.  Each data stream is carried by a unique PID and is identified in the transport stream's Program Map
Table as a User Private Stream.   User Private Streams may or may not be contained in PES packets. 
MPEGID reports the presence of User Private Streams, however, it does not inspect the content.

The following properties are displayed in the Property Pane for a User Private Stream:

PID

The PID property is the value of the PID that is carries the User Private stream.   The PID value may be an
integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be displayed in decimal, or if prefaced
with a "0x", in hexadecimal.  The base in which the PID property is displayed is set by the Edit >
Preferences menu function.  

stream_type

The stream_type property is the stream_type value that is associated with the User Private Stream in the
Program Map Table.   User Private Streams are identified by the stream_type values of 0x80 through 0xFF
(inclusive).  The value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The base in
which the stream_type property is displayed is set by the Edit > Preferences menu function.  

Descriptors

Any descriptors in the PMT that are associated with the data stream are shown.  The hexadecimal data
bytes for each descriptor that is present  are displayed on a separate line.

stream_id 

If the User Private Stream is contained in PES packets, then the stream_id property will be displayed.  The
stream_id is the value that identifies the stream in the PES headers.   The value may be displayed in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the stream_id property is displayed
is set by the Edit > Preferences menu function.
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4.3.14 DVB Subtitle Stream Properties

DVB subtitling systems are specified in ETSI EN 300 743  for carrying program related subtitles and other
graphical elements in MPEG-2 transport streams.  MPEGID reports that a data stream is a DVB Subtitle
Stream if it is associated in the program's PMT with a DVB subtitle descriptor.  MPEGID does not, however,
inspect the content of the stream.

The following properties are displayed in the Property Pane for a DVB Subtitle Stream:

PID

The PID property is the value of the PID that is carries the DVB Subtitle Stream.   The PID value may be
an integer between 16 and 8190 (0x0010 and 0x1FFE).  The value may be displayed in decimal, or if
prefaced with a "0x", in hexadecimal.  The base in which the PID property is displayed is set by the Edit >
Preferences menu function.  

stream_type

The stream_type property is the stream_type value that is associated with the DVB Subtitle Stream in the
Program Map Table.   DVB Subtitle Streams are assigned the value 0x06, or "PES Private Packets".  The
value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the
stream_type property is displayed is set by the Edit > Preferences menu function.  

Descriptors

Any descriptors in the PMT that are associated with the elementary stream are shown.  The hexadecimal
data bytes for each descriptor that is present  are displayed on a separate line.

stream_id 

The stream_id is the value that identifies the stream in the PES headers.   Generally, DVB Subtitle
Streams are assigned a stream_id value of 0xBD, or "Private Stream 1". The value may be displayed in
decimal, or if prefaced with a "0x", in hexadecimal.  The base in which the stream_id property is displayed
is set by the Edit > Preferences menu function.



MPEGID User's Manual, V3.036

Copyright ©  2006 - 2008 Manzanita Systems, Inc.

4.3.15 MPEG-2 Program Properties

An MPEG-2 Transport Stream generally consists of one or more programs.  The properties associated with
each program are displayed by MPEGID as a set of MPEG-2 Program properties. 

The following properties are displayed for each MPEG-2 Program in an MPEG-2 Transport Stream:

program_number

The program_number property is the value that is associated with this program in the transport stream's
Program Association Table (PAT).  It is the same as the Program Number that identifies the program in
the Multiplex Pane.  

PMTPID

The PMTPID property is the PID value of the stream that carries the Program Map Table (PMT) associated
with this program.  The value may be displayed in decimal, or if prefaced with a "0x", in hexadecimal.  The
base in which the PMTPID property is displayed is set by the Edit > Preferences menu function. 

PCRPID

The PCRPID property is the PID value of the stream that carries the Program Clock Reference (PCR)
associated with this program.  The value may be displayed in decimal, or if prefaced with a "0x", in
hexadecimal.  The base in which the PCRPID property is displayed is set by the Edit > Preferences menu
function. 

Program Descriptors

Any descriptors in the PMT that are associated with the program are shown.  The hexadecimal data bytes
for each descriptor that is present  are displayed on a separate line.
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4.3.16 MPEG-1 System Stream Properties

In addition to General Stream Properties and individual elementary stream properties, the following property is
displayed if the input media file is an MPEG-1 System Stream:

Mux Rate

The Mux Rate property is the rate in bits per second (bps) that is specified by the initial mux_rate field in
the stream syntax.  

4.3.17 MPEG-2 Program Stream Properties

In addition to General Stream Properties and individual elementary stream properties, the following property is
displayed if the input media file is an MPEG-2 Program Stream:

Program Mux Rate

The Program Mux Rate property is the rate in bits per second (bps) that is specified by the initial
program_mux_rate field in the stream syntax.  

4.3.18 MPEG-4 ISO Base Media File Properties

In addition to General Stream Properties, the properties of each individual elementary stream contained in the
media file will be displayed in the Property Pane for an MPEG-4 ISO Base Media File.  

4.3.19 MPEG-2 Transport Stream Properties

In addition to General Stream Properties, MPEG-2 Program Properties, and individual elementary stream
properties, the following property is displayed if the input media file is an MPEG-2 Transport Stream:

Transport Rate

The Transport Rate property is the rate in bits per second (bps) that is computed from the PCRs in the
beginning of the transport stream.  Note that the Transport Rate value is only an estimate.  The actual
transport rate may change later in the stream.  
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4.4 Saving a Report File

After you have identified a media file, you can save the results in a report file for future reference.  The report
file is a simple text file that contains all of the information displayed in the Property Pane.

 If you just want part of the Property Pane results in a document, you can select the area that you want, copy
it to the clipboard, and paste it in the document.  

To save a report file:

1. Choose File > Save Report As... from the Menu Bar.  The Save As dialog box will appear.

2. Browse your system to select the desired location to save the report file, enter the report name in the File
Name box, then click Save.

4.5 Demultiplexing an Elementary Stream

The MPEGID program includes a utility that will extract a single elementary stream from an input MPEG-1
system stream, MPEG-2 program stream, MPEG-2 transport stream, or MPEG-4 media file and save it as a
binary file.  The elementary stream can be MPEG-1, MPEG-2, or H.264 / AVC / MPEG-4 part 10 video, MPEG
audio, AAC,  MPEG-4 AAC, AC-3, Enhanced AC-3, DTS, or  SMPTE 302M audio.  Multiple elementary streams
may be extracted from a given input stream file by repeatedly running the Demultiplexer.

 The demultiplexer function is not available with the demo version of MPEGID.

To demultiplex an elementary stream:

1. Open and identify  the input file.  The file must be an MPEG-1 system stream, MPEG-2 program
stream, MPEG-2 transport stream, or MPEG-4 media file.

2. Select the node in the Multiplex Pane that represents the elementary stream you wish to demultiplex.

3. Choose Edit > Demux... from the Menu Bar, or click the right mouse button on the node and then click on
the Demux... function in the submenu.  The Demultiplex As dialog box will appear.

4. Browse your system to select the desired location to save the demultiplexed stream, enter the output file
name in the File Name box, then click Save.  

Depending upon the size of the input file, it may take several minutes for the stream to be demultiplexed. 
A dialog box will display the progress of the demultiplex operation.  When demultiplexing is complete, a
dialog box will display the final size of the output file.  Note: If your input file is on a remote location on a
network, the demultiplexing progress may not be displayed, or it may not be accurately updated because
of network latency.  

20
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4.6 Identifying from the Command Line

The MPEGID installation includes a command line version that enables execution of MPEGID in a command
prompt or shell window.  The output of the command line version is identical to the results that are displayed in
the Property Pane of the GUI version.  The command line MPEGID can be run in batch files or scripts for
high-volume or automated applications.  Its output can be directed to a file for a saved text report.

You may also demultiplex an elementary stream from an input MPEG-1 system stream, MPEG-2 program
stream, or MPEG-2 transport stream using the command line MPEGID.

 MPEG-4 media files can not be demultiplexed from the command line.

 The command line executable is not available with the demo version of MPEGID.

To run the command line version of MPEGID:

1. (Windows only) Open an "MS-DOS" Command Prompt window.

2. At the command prompt or in a script, enter the line:

mpegid [-b buffer_size] input_file

For input_file, give the name of the input media file.  The name may be specified by full path, relative
path, or by filename only.  If only the filename is given, then MPEGID will look for the input file in the
current directory.  Optionally, you can specify the amount of data that MPEGID should inspect by giving
the -b argument where buffer_size is a number of kilobytes.  By default, MPEGID looks at the first 2
MB (2097152 bytes) to identify the input file.

 If you get a message that the name that you entered is not recognized as a command, then the MPEGID
command line executable is not in a location that is recognized by the PATH environment variable.  On a UNIX
system (Linux or Mac OS X) you should either create a symbolic link from the MPEGID program to a directory
that is in your PATH variable or include the location of the MPEGID program in the PATH variable.  On a
Windows system, you need to add the path of the MPEGID installation folder to the PATH variable.

To demultiplex an elementary stream from the command line:

1. (Windows only) Open an "MS-DOS" Command Prompt window.

2. At the command prompt or in a script, enter the line:

mpegid -d id [-v subtype] input_file output_file

For input_file, give the name of the input media file.  The file must be an MPEG-1 system stream,
MPEG-2 program stream, or MPEG-2 transport stream.  If the file is a system stream or program stream,
then id is the value of the stream_id that identifies the elementary stream that will be demultiplexed.  If the
file is a transport stream, then id is the value of the PID that is associated with the elementary stream.  If
the input file is a VOB and you are extracting an Dolby AC-3 audio stream, then the -v argument must be
specified.  In this case, subtype is the value of the VOB subtype that identifies the AC-3 stream.  The
output_file argument is the name for the output elementary stream file.  The input_file and
output_file arguments may be specified by full path, relative path, or by filename only.  If only the
filename is given, then MPEGID will look for the file in the current directory. 
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5 Additional Support

This chapter includes more information about using the MPEG Stream Identifier and where to go if you have
additional questions.  It has the following sections: 

· Frequently Asked Questions (FAQ)  is a list of questions and answers that includes tips for using
MPEGID.

· References  is a reference list of MPEG standards documents.

· Technical Support  tells you how to contact Manzanita Systems for technical support assistance.

5.1 Frequently Asked Questions (FAQ)

Before reporting any problems, please check this list to see if there is a known solution:

· Why does MPEGID identify Video Objects (VOBs) as MPEG-2 Program Streams?

VOB files used in DVD-Video are just MPEG-2 Program Streams with additional data streams that contain
navigation and search information.  MPEGID displays the VOB sub-type that uniquely identifies each
Dolby AC-3 audio stream.

· MPEGID can't identify a stream that I believe is an MPEG stream.  Why not?

The stream may be corrupted or may not be using a valid format.  However, if your think MPEGID is
incorrect in its identification, contact our technical support (e-mail support@manzanitasystems.com).  We
would be interested in analyzing your stream to see why it cannot be identified.  

· MPEGID reports an Duration for my stream that seems wrong.  When I play the stream, the duration is
longer than the one given by MPEGID.  Why?

Your stream may be variable bit rate or there may be a rate change somewhere in the stream.  For all
input streams except transport streams, MPEGID gets the bit rate from the stream syntax, which for
variable rate streams is usually the maximum bit rate.  For transport streams, MPEGID determines the bit
rate from the initial PCRs in the stream.  Because the Duration is calculated from the input file size and the
bit rate, it may be different than the actual duration.

· I have transport stream files that I know contain System Information data streams.  These streams don't
appear in the Multiplex View.  Why not?

For transport streams, MPEGID only identifies elementary streams that are listed in a Program Map Table.
System Information PIDs that are not defined in a PMT will not be shown.

· I've installed MPEGID on my Linux system and I tried running the command line version.  I get a "command
not found" message.  What's wrong?

If you get a message that the name that you entered is not recognized as a command, then the MPEGID
executable is not in a location that is recognized by the PATH environment variable.  You should either
create a symbolic link from the MPEGID program to a directory which is in your PATH variable or include
the location of the MPEGID program in the PATH variable.

· I find MPEGID to be very useful, but I frequently use files that are in a standard format that is not supported
by MPEGID.  Can you add this format?  It would be helpful to me.

We are very interested in getting input from our customers.  We would definitely like to add new formats to
future releases of MPEGID.  Please send your request to support@manzanitasystems.com.  Any
information, e.g., specifications and references, about your format is helpful.  

· MPEGID identifies the output of my encoder as a transport stream.  When I try to play it on a decoder, it
doesn't play correctly.  What is wrong?
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MPEGID does not verify input streams for compliance.  Manzanita Systems offers a compliance and
verification program, the MPEG-2 Transport Stream Analyzer (MP2TSA).  MP2TSA will perform a full
analysis on your transport streams.  Please visit our website, www.manzanitasystems.com, for more
information about MP2TSA. 

· The output in the Multiplex Pane indicates "No data seen for this elementary stream" but I know that that
elementary stream exists.  Also, in the Property Pane, there is a more detailed description of the stream. 
Why is that?

This is because MPEGID only looks at a limited portion of the beginning of the file.  If the elementary
stream data does not occur in that portion of the stream, i.e. it's first occurrence is later in the stream than
what was analyzed, then MPEGID will indicate it did not see the data for this stream.  However, because
the stream was listed in the PMT, it will be acknowledged in the Property Pane as being defined in the
multiplex. 

http://www.manzanitasystems.com/mp2tsa.html
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5.2 References

The following list of documents are the primary references used by MPEGID:

1. ISO/IEC 11172-1:1993: Information technology -- Generic coding of moving pictures and associated audio
for digital storage media at up to about 1.5 Mbits/s - Part 1 : Systems.

2. ISO/IEC 11172-2:1993: Information technology -- Generic coding of moving pictures and associated audio
for digital storage media at up to about 1.5 Mbits/s - Part 2 : Video.

3. ISO/IEC 11172-3:1993: Information technology -- Generic coding of moving pictures and associated audio
for digital storage media at up to about 1.5 Mbits/s - Part 3 : Audio.

4. ISO/IEC 13818-1:2000: Information technology -- Generic coding of moving pictures and associated audio
information -- Part 1: Systems.

5. ISO/IEC 13818-2:2000: Information technology -- Generic coding of moving pictures and associated audio
information -- Part 2: Video.

6. ISO/IEC 13818-3:1998: Information technology -- Generic coding of moving pictures and associated audio
information -- Part 3: Audio.

7. ISO/IEC 13818-7:1997: Information technology -- Generic coding of moving pictures and associated audio
information -- Part 7: Advanced Audio Coding (AAC).

8. ISO/IEC 14496-10 Information Technology - Coding of audio-visual objects - Part 10: Advanced Video
Coding.

9. ISO/IEC 13818-1 Information technology - Generic Coding of Moving Pictures and Audio: Systems --
Amendment 3: Transport of AVC video data over ITU-T Rec H.222.0 ISO/IEC 13818-1 streams.

10. Advanced Television Systems Committee: ATSC Digital Television Standard, Document A/53 Revision E,
with Amendments No. 1 and 2.

11. Advanced Television Systems Committee: Guide to the Use of the ATSC Digital Television Standard,
Document A/54. 

12. Advanced Television Systems Committee: Digital Audio Compression (AC-3, E-CA-3) Standard, Document
A/52 Revision B. 

13. Advanced Television Systems Committee: Program and System Information Protocol for Terrestrial
Broadcast and Cable, Document A/65 Revision C with Amendment No. 1.
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5.3 Technical Support

Manzanita Systems provides this online User's Manual with your copy of MPEGID as the first level of support. 
If you do not find an answer to your question in the User's Manual, contact Manzanita Systems technical
support by phone, fax, or Internet.  Manzanita Systems technical support is available as follows:

Phone

1-858-679-8990
Monday through Friday
9:00 a.m. - 5:00 p.m. PST

Fax

1-858-679-8991

E-mail

support@manzanitasystems.com

Web Site 

www.manzanitasytems.com
Product news, FAQ, maintenance release and update information

mailto:support@manzanitasystems.com
http://www.manzanitasystems.com/index.html
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6 Purchasing and License Agreement

This chapter tells you how to register your copy of MPEGID and acquire a license key to unlock the full version. 
It contains the following sections:

· Registration Benefits  gives the benefits to which you are entitled as a registered user of MPEGID.

· Purchasing a Registered Copy  gives the pricing and ordering instructions for MPEGID.

· Unregistered User License Agreement  is the legal agreement to which you are bound when you install
and run the demo version of the MPEGID program.

· Registered User License Agreement  is the legal agreement to which you are bound when you install
and run the full, registered version of the MPEGID program.

6.1 Registration Benefits

As a registered user, you will receive the following benefits:

· An activation key to unlock the full version of MPEGID.  The full version entitles you to run your copy of
MPEGID for an unlimited time.

· An integrated demultiplexer to extract video and audio elementary streams from input system stream,
program stream , transport stream, and MPEG-4 media files.

· Access to a command line version of MPEGID.

· A software license that entitles you to update your copy of MPEGID with future patches and releases*.

· Free technical support by e-mail, FAX, or mail for at least 90 days starting from your registration date.

· Announcements of future MPEGID releases and new Manzanita products.

* Manzanita Systems reserves the right to introduce an upgrade charge for major new releases.
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6.2 Purchasing a Registered Copy

When you register your copy of MPEGID with Manzanita Systems, you will be given a license key that will
enable you to unlock the full version.  The MPEGID license agreement  entitles no more than one user to use
a single registered copy at a time.  

Pricing

The registration fee for MPEGID is $49.95 USD per single user license.

Purchasing by Credit Card

You must contact Manzanita Systems directly to register and pay your MPEGID registration fee.  You can
use your MasterCard, VISA, or American Express card.  

Your order can be placed 24 hours a day, 7 days a week by fax at 1-858-679-8991 or by e-mail to 
sales@manzanitasystems.com.

You can also call 1-858-679-8990 between the hours of 8:00 AM and 5:00 PM (Pacific Time), Monday
through Friday (except US holidays).

Please provide your name, credit card number, expiration date, billing address, telephone number, and e-mail
address when you order. 

Your license key will be e-mailed to you within one (1) business day.  Therefore, it is important that you
provide your valid e-mail address.  

Submitting a Purchase Order

We can accept purchase orders from government and accredited educational institutions and major
corporations.  Please address questions to sales@manzanitasystems.com, or call us at 1-858-679-8990.
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6.3 Unregistered User License Agreement

This is the legal agreement to which you are bound when you install and run the demo version of the MPEGID
program.  The demo version of MPEGID is provided at no charge to you for your evaluation.  

As an unregistered user of MPEGID you agree to the following:

1. You are free to share copies of MPEGID with others, however, you may not alter the software in any way.

2. You may not sell copies of MPEGID or otherwise distribute it for profit.

3. You may not reverse engineer, decompile, or disassemble the MPEGID program.

4. By installing and using MPEGID, you acknowledge that you have read this license, understand it, and
agree to be bound by all of its terms.

Copyright  MPEGID is owned by Manzanita Systems, Inc. and is protected by United States copyright laws and
international treaty provisions.  Therefore you must treat the MPEGID software like any other copyrighted
material.  You may not print copies of any user documentation provided in "online" or electronic form.

Limited Warranty and Remedies  The MPEGID program is provided "as is" without warranty of any kind,
either express or implied, including, but not limited to warranties of merchantability or fitness for a particular
purpose.  In no event shall Manzanita Systems, Inc. be liable for any damages whatsoever (including, without
limitation, damages for loss of business profits, business interruption, loss of business information, or other
pecuniary loss) arising out of the use or inability to use MPEGID, even if Manzanita Systems, Inc. has been
advised of the possibility of such damage.
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6.4 Registered User License Agreement

This is a legal agreement between you (either an individual or an entity) and Manzanita Systems, Inc.  By
installing the MPEGID software package and by using the full, registered MPEGID program, you agree to be
bound by the terms of this Agreement.  

Grant of License  This License Agreement ("License") permits you to use one copy of the MPEGID software,
which may include user documentation provided in "online" or electronic form.  The MPEGID software is
licensed as a single product.  Its component parts may not be separated for use on more than one computer or
by more than one user at any time.  The software is "in use" on a computer when it is loaded into the temporary
memory (i.e. RAM) or installed into the permanent memory (e.g. hard disk) of that computer.

Copyright  The MPEGID software is owned by Manzanita Systems, Inc. and is protected by United States
copyright laws and international treaty provisions.  Therefore you must treat the MPEGID software like any
other copyrighted material.  You may not copy any printed materials accompanying the MPEGID software
product, nor print copies of any user documentation provided in "online" or electronic form.

Other Restrictions  This License is your proof of license to exercise the rights granted herein and must be
retained by you.  You may not rent or lease the MPEGID software, but you may transfer your rights under this
License on a permanent basis, provided you transfer this License, the MPEGID software and all accompanying
printed materials, retain no copies, and the recipient agrees to the terms of this License.  You may not reverse
engineer, decompile, or disassemble the MPEGID program.

Limited Warranty  Manzanita Systems, Inc. warrants that the MPEGID program will perform substantially in
accordance with the accompanying printed material and on-line documentation for a period of 90 days from the
date of purchase.  Manzanita Systems, Inc. additionally warrants that the MPEGID program is believed to be
free from defect of workmanship and material or viruses.  Manzanita Systems, Inc. will provide technical
support to investigate and resolve any problems reported by you within the warranty period.

Customer Remedies  Manzanita Systems' entire liability and your exclusive remedy shall be, at Manzanita
Systems' option, either (a) return of the price paid or (b) repair or replacement of the MPEGID software that
does not meet this Limited Warranty and that is returned to Manzanita Systems with a copy of your receipt. 
This Limited Warranty is void if failure of the MPEGID software has resulted from accident, abuse, or
misapplication.  Any replacement MPEGID software will be warranted for the remainder of the original warranty
period or 90 days from the date of purchase, whichever is longer.

No Other Warranties To the maximum extent permitted by applicable law, Manzanita Systems, Inc. disclaims
all other warranties, either express or implied, including but not limited to implied warranties of merchantability
and fitness for a particular purpose, with respect to the MPEGID software and any accompanying
documentation.

No Liability for Consequential Damages  To the maximum extent permitted by applicable law, in no event
shall Manzanita Systems, Inc. be liable for any damages whatsoever (including, without limitation, damages for
loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out
of the use or inability to use the MPEGID software, even if Manzanita Systems, Inc. has been advised of the
possibility of such damage.
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